Quartus Tutorial: 8-bit 2-1 Multiplexer on the MAX7000S Device

Before you begin:

Create a directory in your home workspace called ese343.
Note: You will use this folder to store all your projects throughout the semester.

Copy the files DEC _7SEG and mux_2input pin_assignment from the course website into the
directory you just created.
1. Open Quartus II: Open a Linux/Unix terminal and type quartus.
2. Create a new Quartus project (.gpf):
2.1. Click File -> New Project Wizard.

2.2. Click Next at the bottom of the New Project Wizard: Introduction page.
You will now be on page 1 as shown below.

New Project Wizard: Directory, Name, Top-Level Entity [pa x|

‘what iz the working directory for this project?

L
Imux_2input _I

‘what iz the name of the top-level design entity for this project? Thiz name is caze sensitive
and must exactly match the entity name in the design file.

Imux_2input |

Usze Exizgting Project Settings ...

‘what iz the name of this project?

< Back I Meut » Finizh Cancel

2.3. Specify the working directory:
a) Click the ... button to the right of field (a) in the figure above to browse for the
csc343 directory you created above.
The path to this directory will be shown in field (a).



b) Type \mux_quartus after the path that was just displayed in field (a).
Note: This directory does not exist, but Quartus will make it for you.

¢) Specify the project name: Type mux_2input in field (b).
Quartus automatically names the top-level design in field (¢) the same as the
project name.

2.4. Click Next at the bottom of page 1 of the New Project Wizard.
You will be on page 2 as shown below.

New Project Wizard: Add Files [page 2 of 5] 1[

Select the design files you want to include in the project. Click Add All to add all desian files
i the project directory to the project. Mote: you can always add design files to the project
later.

Fiename:  |./../DEC_TSEG.vhd |_| Add

File: harme | Type | A Al

Femove

Properties

M

Dawn

Specify the path names of any non-default libraries. User Libraries. .. |

¢ Back | Newt » | Firish | Cancel

2.5. Click the ... button to the right of field (a) in the figure above to browse for the file
DEC _7SEG, then click OK.

2.6. Click Add, then click Next at the bottom of page 2 of the New Project Wizard.
The You will now be on the Family & Device Settings page as shown below.



New Project Wizard: Family & Device Settings [page 3 of 5] |

Select the family and device yau want to target for compilation.

Famib:  [Max70005 =l

Target device

" Auto device selected by the Fitter from the 'Available devices' list

%' Specific device selected in 'Avalable devices' list

Available devices:

EPM70R4SLCE4-7 il
EPM7I: fd-7 Packane: Ay -
EPM71R0SLCS4-7

Pin count: 84 hd

Speed grade: I? 'l

Core voltage: 5.0V

[V Show Advanced Devices

- Companiah device

HardCapy [l I 'l

¥ | Liit DSF & Bt to HardCopy [l
fevice resauces

¢ Back I et > I Finish | Cancel

2.7. Set the Family name: Select Max7000S from the drop-down menu in field (a).
2.8. Set the Speed grade: Select 8 from the drop-down menu in field (b).
2.9. Set the Pin count: Select 84 from the drop-down menu in field (c).

2.10. Select EPM7128SLC84-7 from the available devices in field (d).

Note: These settings are only used when implementing the Altera Max chip on the UP2 Board. The Altera
Flex on the UP2 and the Altera Cyclone on the UP3 Board have different settings.

2.11. Click Next at the bottom of page 3 of the New Project Wizard.

2.12.Click Next at the bottom of the EDA Tool Settings (page 4).
You will now be on Summary page as shown below.



New Project Wizard: Summary [page 5 of 5] 5[

“when you click Finigh, the project will be created with the following settings:

Fraject directaory:
C: frive5B63/cec 343/ mux_quartus/

Project name: mus_2input
Top-level degign entity; mus_2input
Murmber of filez added: 1

Mumber of uger libraries added: 0

Dievice azzsignments;

Family name: b FO00S

Device: EPh71285LCR4-7
EDA tools:

Diesign entm/aynthesis: <Mones

Simulation; <Miones

Timing analyzis: <Mone>

< Back | et I Finizh I Caneel |

2.13. Click Finish at the bottom of page 5 of the New Project Wizard.
3. Create a new block diagram file(. bdf).

3.1. Click File->New.
A new window appears like the one below.

New x|

Device Design Files | Software Files | Dther Fies |

E
Werlog HOL File
YHOL File

Cancel |

3.2. Select the Block Diagram/Schematic File option and click OK.
A new window appears like the one below.



f ) Block1.bdf

i Block1.hdF
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3.3. Select the Symbol Tool from the toolbar on the left of the block diagram.
A new window appears like the one below.

x

Libraries:

B & /ateralquartusBD/ibranies” a
HET megafunctions =
HEY others
B primitives =

HES buffer
EHE lagic
C MR andi?

dl

{EES
‘ Iand2
|

[V Repeatinsert mode
I™ Insert symbal a3 block
[ Launich fega/izard Flugrm

tegaiwizard Plug-In Manager... |

1[4 I Cancel |

3.4. Click on primitives -> logic -> and?2 to get the and symbol and click OK.
The cursor now acts as a stamp in the block diagram window. It will stamp an and
gate every time you click inside the window.

3.5. Place two and gates inside the block diagram window referencing the Multiplexer
schematic below.



3.6. Right-click inside the block diagram window or click on the Selection and Smart
Drawing Tool at the top of the toolbar to finish using the and gate.

Note: You can delete mistakes by right-clicking on an object and selecting Delete.

3.7. Place one or2 symbol and one not symbol in the block diagram window referencing
the schematic above.

Note: These symbols can be found in the same place as and2..

3.8. Place three input pins and one output pin in the block diagram window according to
the schematic above.

Note: These symbols can be found in primitives -> pin in the Symbol window.

3.9. Select the Orthogonal Node Tool from the toolbar on the left as shown below.
’E ﬁ multiplexer. bdf

3.10. Connect each object as shown in the schematic above:
a) Click as close as possible to one object.
b) Drag the connection toward a second object until a small box appears.

Note: A unconnected wire shows an X along the wire when the wire is not highlighted.

3.11. Name each pin:
a) Double click on the upper left-most input pin.
b) Type Sel in the Pin name(s) field and click OK.
¢) Name the second input pin 10 and the third input pin I11.
d) Name the output pin O.

3.12. Save the file as multiplexer.bdf.



4. Create a symbol to represent the above file:
4.1. Click inside the multiplexer.bdf to make sure this is the active window.

4.2. Click File -> Create/Update -> Create Symbol Files for Current File as in the figure
below.

Note: Make sure the multiplexer.bdf file is highlighted before creating the symbol.

O mew... el | N2 ||mux_2input j ‘ =
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12,) Mew Project Wizard. .
EE Open Project. .. Ckrl+3
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5. Click on the Files tab in the Project Navigator window shown below.
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6. Double-click on DEC_7SEG.vhd to open the file.

7. Create a symbol for this file as well using the process described above.

8. Create a new block diagram file:

8.1. Repeat steps 5.1, 5.2, and 5.3.
A new Project folder will appear above the altera libraries folder as shown in the

figure below.

Symbaol

Libraries:

= E= Project

LEF Multiplexor
3 o alkeradquartusS0/dibranies!

Marne:

Il:let:_?seg _I

[V Repeat-insert mode
I Insert symbol as black
I | Launch b egsiizard Flug-r

Megaizard Plug-ln Manaager. .. I
Ok I Cancel I

hex_digit [3..0]

8.2. Click on the Project folder, select dec_7seg and click OK.

8.3. Place one dec_7seg symbol in the block diagram referencing the schematic below.

dec_iseg Ll
hex_digt  segment_a OUTPUT > 3
segment_b e e
segment_c L
segment_d AT
sagment_s L
cagment_f T
segment_g L
inst il
L GUTEIT 0 e

8.4. Place one Multiplexer symbol in the block diagram.

8.5. Place three input pins and seven output pins as shown in the schematic above.



8.6. Connect all objects as shown above using the Orthogonal Node Tool.

8.7. Name all pins in the following order from top to bottom, left to right:
Input: S, 10, I1
Output: O, a, b, ¢, d, e, f, g

8.8. Save the file as mux_2input.bdf.

9. Compile your design:

9.1. Click Processing -> Start Compilation as shown below.

Quartus will show the status of the compilation process in the Status window on the
left side of the screen and will show a confirmation of completion.
ants | Processing Tools  Window  Help
| s @ Stop Processing Chr+-5hift+C Iﬁ
Bl oot Compilation Chrl+L |
|_% @ Analyze Current Eils
Start: 4

T Update Memory Initialization File
E @ Compilation Report Chrl4+R

—

Skart Compilation & Simulation  CerH-Shift+E

Generate Functional Simulation Metlist

= . .
!_L Start Simulation Chrl+I
Sirnulation Debug L
[n)
F &b Simulation Report Ctrl+Shift+R ﬁ
N
é & cCompiler Tool Co

— = Simulator Tool
LE @ Timing Analyzer Tool C
# ﬁf" PowerPlay Power Analyzer Tool I

9.2. Click OK in the confirmation window and exit out of the Compilation Report window
that is shown below.

JOCHTTRCTIIOR = OF dan Tosr TS

& Compilation Report - Flow Summary

Compilation Report
Legal MNotice
== Flow Summary
EE Flow Settings
B Flow Elapsed Til

Flow Log Flow Status Successhul - Thu Sep 14 01:47:47 2006
m || DB 14304/26/2006 5. FullVersion
mis_ZinpLit

@ Full Compilation was successful {0 errors, 4 warnings) g B!
MAKFO005

EPM71285LCE4-7
Final
s Yes
Total macocels TH128(5%)

Tatal ping

14/63(20%)



10. Create a vector waveform file (.vwf):

10.1. Click File -> New, and click on the Other Files tab as shown below.

Device Design Files I Software Filez  Other Files |

AHDL Include File

Block Symbol File

Chain Dezcription File
Hexadecimal [Intel-Format] File
kdemory [nitialization File

SignalT ap |l File
Tcl Script File

Text File

Vechs

wefarm File

X

10.2. Select Vector Waveform File.

[ o |

Cancel

A new window will appear as shown below.

R waveform1.ywf -0l x|
taster Time Bar: | 11.58ns <| >| Pointer:| 300 pg Intewal:l 11285 nz Stalt:| End:l
ps 10.0 s 200z |
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a
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Paste Zhr|HY,

Paste Speciall.

Repeat Paste, .,

Delete Del
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Insert Node or Bus...
4 b
KR e, , i




10.3. Right-click under the Name field in the left section of the waveform window and

select Insert Node or Bus.
A new window will appear as shown below.

x
Marne: I ak. |
Type: IINF'UT j Cancel |
Walue type: IS-LeveI LI IWI
Radix: IBinar}l LI
Bus width: |1
Start index: IU
[~ Display gray code count az binary count

10.4. Select Node Finder on the right side of the window.

A new window will appear as shown below.

Mode Finder

Mamed: I"

Look in: |y

;I Filter: IF'ins: all ;I

Customize. ..

[ Lt

e,
;IJ ' Include subentities Stap |

Modes Found: Selected Modes:
MHame I Azzignments I Tupe Mame I Azzignments I T

¥ a Urazsigned  Olutput

¥ b Urazsigned  Olutput

Lo Unassigned  Dlutput

o d Unassigned  Dlutput

I e Unassigned  Dlutput

Lo Unassigned  Dlutput

¥ g Unassigned  Dlutput _>|

=0 Unaszigned  Input

=1 Unaszigned  Input LI

-5

Unazsigned Input
< |

10.5. Click on the List button the right side of the window.
All input and output pins in the design will appear in the left window as show above.

10.6. Select S then click on the > button in the middle of the window.

10.7. Repeat step 12.6 for 10, I1, and O in that order.

Xl

ok |
Cancel |




10.8. Click OK to exit the Node Finder window and OK again to insert these items into
the vector waveform as shown below.
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10.9. Click on I1 and select the Forcing High button from the toolbar on the left.
This sets 11 to always input 1 as seen above.

10.10. Click and drag over the interval from 10.0ns to 20.0ns in the S signal and select the
Forcing High button.
This produces a step in the signal shown below.

m A ﬁ mLE_2input, bdf | '@ Lt 2input. sl
o @\ M azter Time Bar: | 0psz *l Pl Fointer: | 45 ns Interval: |_
0 ps 10.0 ns 20.0 ns
o Marne 0ps
4B |
@2 I
N [ 10
r JJ_" [ g I
o
== MFarcing High (1)
WL yE ]

10.11. Save the file as mux_2input.vwf.

11. Simulate your design:



11.1. Click Processing -> Start Simulation as shown below.

|F‘ru:u:essing Tools  Window  Help

: 4l stop Processing CErH-ShifEC

P Start Compilation ChFl4L
@ Analvze Current Ele
Stark L4
pdate Memory Initialization File
@ Compilation Report Ctrl+R

Start Compilation & Simulation  Cerl+ShifE+E

Generake Funckional Sirmulation Metlisk

_E'_Ll Start Simulation
Simulation Debug L4
&2 simulation Report Chrl+Shift+R

o 1 0 o e 20 DT L

[ Campiler Toal

b Simulator Tool

| @ Timing Analvzer Toal

lr;;’? PowerPlay Power Analvzer Toaol

N T

11.2. Click OK once the confirmation window appears, but DO NOT exit out of the
Simulation Report window.

Note: The Simulation Report window shows the output of your design.

11.3. Analyze the output in the Simulation Report. Notice that when S is 0, the output is
whatever 10 is, and when S is 1, the output is whatever I1 is.

12. Download your design onto the chip:

12.1. Click Assignments -> Import Assignments.

Assignments  Processing  Tools  Window

% Device. ..

Z# Pins

B Timing Settings. ..

22 EDA Tool Settings. ..

< Settings. .. Crrl4-5hift+E

Timing Wizard. ..

& Assignment Editar  Crrl+Shift+a

£ Pin Planner Chrl+Shift-+M
Remove Assignments., ..

ré Lemobe Assigrments, ..

i‘i. Back-Aannokate Assignments. ..

ﬂ Import Assignments. .,

Export Assignrments. .,

Time Groups...

% Timing Closure Eloorplan
@ LogicLock Regions Window  Alk+L
E@ Design Parkitions Window  Alt+D




£, Hardware Setup...| |B}'tEB|EStEf” [LFTT]

12.2. Click on the ... button in the Import Assignments window to browse for the
mux_2input _pin_assignment file you copied at the beginning of the lab and click OK.

Import Assignments ﬂ

Specify the source and categonies of assignments to import. Click LogicLock [mpart File Assignments
to zelect LogizLock Import File(s).

—Agzignment source :
[Categaries...

* File name: |£ESE 342 Fall 06/mux_Zinput_pin_assignment.cey | L. |

Advanced...

i

" Usze LogicLock Impart File Azzighments

Logiclack [mpart File Szsignmemnts...

v Copy existing assignments inka mus_2input. gsf. bak before imparting

]

Cancel

12.3. Save your design and recompile to include the pin assignments.
Click Tools -> Programmer.
A new window appears as show below.

Mode: |JTAG

s

j Progress: 1]

Wi Start

it Stop

ﬂlﬂ Euta Detect
X Delete

[ Add File...
T Change File...

ml SaveFile...

(2 fdd Device...

FERBRREE

Program.
Configure

Security
Bit

File |Jzercode E xaming

O0OOFFFE

Checksum

12.4. Click Hardware Setup and make sure that the ByteBlaster(MV) hardware is listed.
If it is not listed,

a) Click Add Hardware and select ByteBlaster(MV) for the Hardware Type
b) Select Parallel Port LPT1 and click OK.

12.5. Click on the Program/Configure checkbox of your mux2_input.pof file in the



Programmer window and click Start.
If your file is not listed in the window, click Add File, select your file and click OK.

13. Compare your results on the board with that of the waveform. Try as many combinations as
you can and see how many outputs you can get to display correctly.



